[ArchLinux] Choix de la sortie son par défaut

Après avoir effectué une mise à jour et redémarré mon système il y a de cela un mois environ, j’ai constaté que je n’avais plus aucun son en sortie de mes haut-parleurs. Après bien des recherches, j’ai remarqué que le son sur la sortie HDMI semblait fonctionner.

En cherchant les sorties disponibles sur ma machine, je découvre donc que la sortie 0 utilisée jusqu’à présent, du moins dans mes souvenirs, est désormais la sortie HDMI. J’indique donc au système d’utiliser la sortie 1 :

pactl set-default-sink 1

Retour du son dans mes haut-parleurs et vérification de la sortie utilisée.

# pactl list sinks short
0 alsa_output.pci-0000_01_00.1.hdmi-stereo-extra2 module-alsa-card.c s16le 2ch 44100Hz SUSPENDED
1 alsa_output.pci-0000_00_1b.0.analog-stereo module-alsa-card.c s16le 2ch 48000Hz RUNNING

En outre, lorsqu’il s’agit de débuger un problème de son, je commence généralement par faire un tour du côté de alsamixer et pavucontrol.

Toutefois, il s’avère que si cette opération suffit pour la session courante, la configuration ne persiste pas au redémarrage du système. Pour configurer la carte par défaut, je commence donc par lister une nouvelle fois les sorties disponibles.

# pacmd list-sinks | grep -e 'name:' -e 'index:'
  index: 0 name: <alsa_output.pci-0000_01_00.1.hdmi-stereo-extra2>
* index: 1 name: <alsa_output.pci-0000_00_1b.0.analog-stereo>

Ensuite, j’édite le fichier /etc/pulse/default.pa pour y ajouter la ligne suivante :

set-default-sink alsa_output.pci-0000_00_1b.0.analog-stereo

Après un redémarrage du système, le son sort à nouveau de mes hauts-parleurs.

Victor

Auteur : Victor

Libriste convaincu, j’administre ce serveur et son domaine et privilégie l'utilisation de logiciels libres au quotidien. Je construis progressivement mon "cloud" personnel service après service pour conserver un certain contrôle sur mes données numériques.

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *